Welcome, Guest. Please login or register.
Did you miss your activation email?
November 20, 2017, 09:05:35 PM
Home Help Search Login Register
News:

+  DIY DataRecovery.nl Support forum
|-+  Support
| |-+  DiskPatch (Moderators: Tom, Joep)
| | |-+  Windows 10 Anniversary Update - Endless reboot
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Windows 10 Anniversary Update - Endless reboot  (Read 1490 times)
Louis.CT
member

Posts: 1


« on: December 12, 2016, 11:52:06 AM »

I have a Dell XPS8300 PC with following configuration:
CPU:   Intel Core i7 2600 @ 3.40GHz      Sandy Bridge 32nm Technology
RAM:   16,0GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard:    Dell Inc. 0Y2MRG (CPU 1)   
Graphics:   CX271 (2560x1440@60Hz)
      1024MB ATI AMD Radeon HD 6700 Series (ATI)   
Storage:   238GB Samsung SSD 850 PRO 256GB (SSD)
      1863GB Seagate ST2000DM001-9YN164 (SATA)   
PC uses BIOS

This PC did run Win7 on the 2 TB Seagate disk, I did later added the 238 GB SSD ( I did the reconfiguration by means of the Samsung software). The SSD contained the System Disk and a Windows Recovery  partition.
In February 2016 I did an upgrade from Win7 to Win10 with the same configuration.
End October there was a forced upgrade by Microsoft to Windows 10 Anniversary Update that resulted in an endless reboot. As I take twice a month an Acronis True Image backup I did reload this backup and everything did run again as normal. A few day later, the same scenario did occur again.
I did download the complete installation ISO of Windows 10 release 1607 and did try to do a manual upgrade with the same results. I then tried to repair Windows with the 1607 ISO and typed at the command prompt:    BOOTSECT :NT60 C:/mbr. After this command I couldn’t  boot anymore.
I did try to solve this problem with several software’s  without any positive result.
Logged
Joep
Developer and Support Tech
Administrator
member
*****
Posts: 1457


WWW
« Reply #1 on: December 12, 2016, 01:28:00 PM »

Hi,

Looks like a bit of a screw up.

MBR looks like a mix up between and MBR and the boot sector for a partition. Boot code looks boot sector code (NOT MBR boot code). But is also contains a partition table which is self referencing: Is is located in sector 0 and points to sector 0 as well. Really weird.

You say you tried a lot. Like what? It helps to know.

"BOOTSECT :NT60 C:/mbr". This should never screw up like this. But did you check drive letter C: was actually assigned using diskpart for example?

Bit of background:

Normally MBR = bootcode + partition table.

bootcode does some simple checks > then reads partition table > then reads sector to which boot partition points to > executes code found there.

If the partition table points to sector zero (the MBR), then theoretically it would execute that code again. And again. And again ...

But the boot code in your MBR looks like boot SECTOR code. And it also contains a partition table. Which boot SECTORS normally do NOT.

Now, we can place MBR boot code there, but then you'd still be stuck with a partition table that points to sector 0, which as I explained doesn't work well. Also, to add to the confusion it contains a valid BPB ... so all values you normally find the boot sector that describe a volume (file system, cluster size etc.), are there.

Don't know what to make of this ...

So, what's the goal? If data is of no concern I'd start over.
Logged

--
Kind regards,
Joep
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!